따뜻한 대한민국 겨울만들기

Snow Leopard (Mac OS X 10.6.8) 에서 XCode 4.2를 설치 후 현재 최신인 iOS 5.1 SDK 를 사용할 수 있습니다.



1. Snow Leopard 에서 XCode 4.2 설치하기


- XCode 4.2 for Snow Leopard 다운로드https://developer.apple.com/devcenter/ios/index.action


다운로드 후 설치하기 전,

OS X 날짜를 2012년 1월 이전으로 설정하고 설치를 진행해야 정상적으로 설치 됩니다.


(위 링크로 가서 아래로 내려보면 XCode 4.2 for Snow Leopard Download 가 있습니다)



2. XCode 4.2 에서 5.1 SDK(최신) 사용하기


1. 4.2 로 설치하면 최신 SDK 를 사용하지 못합니다. (5.0 이 기본 셋팅 되어 있음)

최신 SDK 를 사용하시 위해선, 먼저 최신 버전 SDK 를 다운로드 합니다.


- 최신버전 SDK 다운로드(XCode 4.3.2 for Lion)

https://developer.apple.com/downloads/index.action


2. 다운로드 받은 dmg 파일을 DiskImageMounter 로 엽니다. (오른클릭 → 다음으로 열기 → DiskImageMounter로 마운트)


3. Finder 상에 마운트 된 것을 확인하고,


4. 관련 파일들 복사

1.

/Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk 폴더를 

/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/ 폴더로 복사

2.

/Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.1.sdk 폴더를 복사

/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/ 폴더로 복사

3.

/Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/5.1\ \(9B176\) 폴더를

/Developer/Platforms/iPhoneOS.platform/DeviceSupport/ 폴더로 복사

4.

/Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/version.plist 파일을

/Developer/Platforms/iPhoneOS.platform/version.plist 로 복사 (기존것 백업)


이런식으로 진행하면 되고, 

터미널 상 명령어는 아래와 같습니다.

sudo cp -R /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/

sudo cp -R /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.1.sdk /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/

sudo cp -R /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/5.1\ \(9B176\) /Developer/Platforms/iPhoneOS.platform/DeviceSupport/

sudo cp /Developer/Platforms/iPhoneOS.platform/version.plist /Developer/Platforms/iPhoneOS.platform/version.plist.bak

sudo cp /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/version.plist /Developer/Platforms/iPhoneOS.platform/version.plist


5. XCode 재실행


이렇게 하면,

부득이하게 Snow Leopard 를 사용해야 하는 사람들은 XCode 4.2 로 최신버전 SDK 를 사용하여 개발할 수 있게 됩니다.


※ Reference

http://www.iphonedevsdk.com/forum/iphone-sdk-development/100229-snow-leopard-sdk-5-1-a.html

http://learnipadprogramming.com/2012/03/24/using-xcode-4-2-on-snow-leopard/

http://stackoverflow.com/questions/9614918/xcode-4-2-snow-leopard-and-ios-5-1

http://nolran.tistory.com/38


  1. BlogIcon Na~!

    | 2012.09.03 20:29 | PERMALINK | EDIT | REPLY |

    디스크이미지마운터는 없는거 같은데 어디서 받아야되나요? ;ㅁ;

  2. BlogIcon 꽃녀

    | 2012.09.07 10:15 신고 | PERMALINK | EDIT |

    맥OS에 기본적으로 있는 프로그램입니다. .dmg 파일에 우클릭 하시면 보일건데요.. ' ';;

  3. BlogIcon Na~!

    | 2012.09.07 14:34 | PERMALINK | EDIT | REPLY |

    감사합니다~ 덕분에 5.1.1 폰도 개발 할 수 있게 됬어요~
    혹시 아이패드 6.0 beta4도 같은 방식으로 하면 될까요?

  4. BlogIcon 꽃녀

    | 2012.09.07 15:05 신고 | PERMALINK | EDIT |

    ㅋㅋ 그렇게는 해보지 않았는데요. 음.. 되지 않을까요. 잘 모르겠네요 ㅎㅎ

  5. RHCRO

    | 2012.09.19 14:43 | PERMALINK | EDIT | REPLY |

    ㅠㅠ 지금 10.6.8 snow leopard 쓰고있는데 4.2를 못찾겠어요...ㅜㅜ 4.2 for lion 만 있고 그 아래 3.2.8 for snow leopard 있고... 어디서 받아야 하나요? ㅠㅠ

  6. RHCRO

    | 2012.09.19 20:24 | PERMALINK | EDIT | REPLY |

    아... 이게... 개발자 용으로 등록해야만 보이는거군요...;;; 결국 어떻게 어떻게 받았습니다... 이제 해봐야지요 ㅎ

Write your message and submit
« PREV : 1 : ··· : 3 : 4 : 5 : 6 : 7 : 8 : 9 : 10 : 11 : ··· : 61 : NEXT »